I still can't log in successfully. What can I do?

ILok Issues

Please check the version of your ILok License Manager. DeMIX Pro and DeMIX Essentials require ILok License Manager 5.5.2 or above to operate. If your ILok License Manager is older than 5.5.2, please download the latest version to try again.

Please ensure that you have a cloud session open if you are using ILok Cloud. This can be achieved on ILok License Manager by clicking file -> "Open Your Cloud Session"


Get App?